Network Upgrade - Planned Maintenance
Scheduled for August 18, 2025 at 9:00 AM – August 17, 2025 at 11:30 PM
Affects
[ECO-VPS] Virtual Servers
In progress
August 18, 2025 at 9:00 AMIn progress
August 18, 2025 at 9:00 AMMaintenance is now in progress
Planned
August 18, 2025 at 9:00 AMPlanned
August 18, 2025 at 9:00 AMOn August 18 from 11:00 to 11:30 a.m. (UTC+2), maintenance will be carried out by our technicians in order to upgrade our core router.
The maintenance will include a downtime of about 25 minutes. At the end of the maintenance all servers will automatically come back online.
All updates will be posted here and in our official Discord channel.
For any needs or questions you can contact us directly.
Completed
August 18, 2025 at 9:00 AMCompleted
August 18, 2025 at 9:00 AMThe maintenance has been successfully completed.
Due to unexpected technical issues, the operation took longer than anticipated.
We sincerely apologize for the inconvenience, and as compensation, we have automatically extended the expiration of all servers by 2 days.
Thank you for your patience, for any inquire you can contact us directly.