Planned Maintenance - Network Upgrade
Scheduled for July 30, 2025 at 2:00 PM – 5:50 PM
Affects
Servers
Under maintenance from 2:00 PM to 5:50 PM
[ECO-VPS] Virtual Servers
Under maintenance from 2:00 PM to 5:50 PM
Dedicated Servers
Under maintenance from 2:00 PM to 5:50 PM
Datacenter
Under maintenance from 2:00 PM to 5:50 PM
Fiber-Connection to MIX
Under maintenance from 2:00 PM to 5:50 PM
Completed
July 30, 2025 at 5:50 PMCompleted
July 30, 2025 at 5:50 PMMaintenance has completed successfully.
In progress
July 30, 2025 at 4:00 PMIn progress
July 30, 2025 at 4:00 PMMaintenance is now in progress
Planned
July 30, 2025 at 2:00 PMPlanned
July 30, 2025 at 2:00 PMOn July 30 from 3:00 p.m. to 5:30 p.m. (UTC+2), maintenance will be carried out by our technicians in order to improve the fiber optic connection.
The maintenance will include a downtime of about 1 hour which may increase (in the indicated time window) if necessary.
At the end of the maintenance all servers will automatically come back online.
All updates will be posted here and in our official Discord channel.
For any needs or questions you can contact us directly.