Scheggia Cloud - PayPal Checkout - Temporarily Suspended – Incident details

All systems operational

PayPal Checkout - Temporarily Suspended

Resolved
Degraded performance
Started about 1 year agoLasted 2 days

Affected

Websites

Degraded performance from 1:37 AM to 9:15 AM

Client Area - billing.scheggia.cloud

Degraded performance from 1:37 AM to 9:15 AM

Updates
  • Resolved
    Resolved

    After careful review we have decided to discontinue PayPal payments, all future purchases and renewals will be processed through Stripe and Crypto.

    Through Stripe and this change we will no longer charge 5% commission on orders from the end of September 2023, and we have also joined the Stripe Climate programme, donating a portion of payments to the removal of carbon in the environment.

    Our supported payments are now:

    • Cards (Visa, Mastercard, American Express, Discover, Diners Club, China UnionPay)
    • Apple Pay / Google Pay
    • BLIK, Bancontact, EPS, giropay, iDEAL, Sofort, Klarna
    • Bank Transfer / SEPA Direct Debit
    • Crypto (BTC, ETH, USDC, USDT, DOGE, LTC, DAI, BCH, APE, SHIB, MATIC)
    • Paysafecard

    If you have any doubts or questions, please open a ticket in our discord server or via chat where we will work together to find the best solution for your order.

  • Investigating
    Investigating

    We are experiencing some problems processing payments through PayPal, so currently you can only purchase or renew via Credit Card / Crypto. So we recommend that you transfer the funds to your card to complete the payment.

    We are working together with PayPal support to resolve the issue as soon as possible and ensure the best experience while purchasing, thank you for your patience.

    Updates will follow; if necessary you can contact us via ticket, email or live chat.